Solax X1 G4 with HV Traction Battery - Older Firmware anyone?

Topics concerning storage of renewable energy e.g. home battery systems
Post Reply
Posts: 1
Joined: Sun Aug 13, 2023 11:02 am

Solax X1 G4 with HV Traction Battery - Older Firmware anyone?

Post by fox123 »

Hi Everyone.

Thanks for this fantastic thread and info which has been invaluable.

Short Version: Does anyone have earlier firmware for Solax X1/G4 (before ARM 2.03 | DSP 2.07)? 🙏 Also see attached new BMS CAN recording with interesting new frames from the Triple batteries. 🎁

Long Version:
I am trying to integrate a new Solax X1 G4 with a HV traction battery (320-390v) using my own DIY gateway for BMS CAN communication.

I already have software that emulates the Solax Can protocol and this works perfectly on other older inverters of the same model and also on FOX ESS models too. My HV battery also works great already so no issues there.

However the G4 inverter I am setting up now is only a few weeks old and has much newer firmware (Firmware: ARM 2.03 | DSP 2.07) which seems to have changed the can protocol in some subtle way as I am now getting the dreaded IE07 BattVoltFault error about 12seconds into the "checking" phase persistently.

In lead acid mode with my HV battery it works fine so no issues with wiring etc. When in this mode (having passed the checking phase) the fault is more or less instant when switching on the BMS CAN.

I have plugged the same inverter into another known working Solax Triple battery setup (1 master 1 slave) and it works fine. I have recorded the can communication (attache) and adjusted the voltage/SoC for my HV batt and played back but still same fault.

Probably a red herring but the only weird thing is that the inverter reports a voltage as being 6v lower than the actual of the HV pack (measured by pack BMS and multimeter). Not sure why that would be. I have tried sending real voltage and voltage inverters is reading (minus 6v) on BMS CAN frames but same issue - battvoltfault.

Based on some comments on this thread about the 1877 frame I have also tried multiple version of this to make the inverter think that its connected t multiple different battery brands but same issue. I was thinking perhaps Solax are hardcoding some voltage limits for each battery type and thats why I had the fault but doesnt seem to make any difference.

So basically I think that Solax have made some subtle change to the protocol on firmware ARM 2.03 and DSP 2.07 (possibly trying to block use of 3rd party batteries)

ATTACHED: Please find attached recorded Can frames from 2023 Solax X1 G4 with 2 triple batteries. Solax certainly added several new frames 187A/B/C/D. This is what the inverter reports the battery as:

BatBrand TP007
BatteryM and S version 2.00
BMS Code
BAT-M 1.02
BAT-S1 2.06 50
BAT-S2 2.06 50
BAT-S3 2.04 50
BAT-S4 2.04 50

REQUEST: I was wondering if someone has an earlier version of the inverter firmware that I could flash to see if I can get this to work. I would ask Solax but I doubt they will let me downgrade like this and not even sure which previous versions to ask for?

Any help much appreciated as several days/evenings sunk into this one now.
Solax X1 G4 with Triple Batt from startup to
(10.03 KiB) Downloaded 128 times
Posts: 110
Joined: Tue Sep 22, 2020 6:48 pm
Has thanked: 15 times
Been thanked: 22 times

Re: Solax X1 G4 with HV Traction Battery - Older Firmware anyone?

Post by bigmotherwhale »

I noticed in some of the logs i got from a solax X1 there is a date and time stamp in the data somewhere.
Could there be something like that here?
User avatar
Posts: 1199
Joined: Tue Apr 28, 2020 3:50 pm
Location: The Netherlands
Has thanked: 16 times
Been thanked: 34 times

Re: Solax X1 G4 with HV Traction Battery - Older Firmware anyone?

Post by EV_Builder »

Is this the original log or the modified attempt one?
Converting an Porsche Panamera
see for bespoke BMS modules.
Post Reply