Morning trips

Introduction and miscellaneous that we haven't created categories for, yet
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Morning trips

Post by FFMan »

I have this occur a few times recently but this morning took the longest to get going. Only seems to occur at home after a charge to say 3.95v/cell = pack voltage 379

When i try the initial pull away, the motor shudders and trips, and i have to restart the inverter. This morning took about 5 goes to get moving, and then did 15 mile round trip with a stop (school run) no problem, and i don't think i ever see the issue when resuming a journey on part charge.

My udxmax is set to 400, is this possibly causing a trip or where else should i look ?
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
johu
Site Admin
Posts: 5537
Joined: Thu Nov 08, 2018 10:52 pm
Location: Kassel/Germany
Has thanked: 147 times
Been thanked: 917 times
Contact:

Re: Morning trips

Post by johu »

Does it get worse if you charge even higher, like 4.05V?

Has this recently started and could be temperature/condensation related?

udcmax is just a derater, it limits maximum throttle as you approach it.
Support R/D and forum on Patreon: https://patreon.com/openinverter - Subscribe on odysee: https://odysee.com/@openinverter:9
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

i'll try charging higher tomorrow and see if that makes a difference.

i used it for a short run this morning, and now have just charged it back to 3.95, so will be interesting to see later if it happens again. It might indicate if it is charge level related or ''first use of the day" related which most of the time happen at the same time but not this afternoon.

i'll also check at the weekend inverter sealing, it is getting cold and damp here.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

ok - so on the afternoon run, having charged it back to 3.95 it was fun. the trips might just be a morning thing i.e. condensation etc

its topping up now, will use this evening, and then will try again in the morning after an overnight charge to say 4v.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

This is odd, I charge to 393V without issue. Does your inverter report any error?
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

Charged it to 4.05/cell

Got 1 trip pulling away, inverter reports OVERCURRENT, then no issue after restart. I don't think the issue relates to the amount of charge though, always first pull away of the day, but not necessarily first pull away after a charge.

Yesterday i sealed up all the apertures in the inverter once i had used it, pretty sure it's fairly air tight now.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

So this morning, had to give up on using the EV. It kept tripping trying to get it out of the parking bay. Tried like 15 resets.

It rained a lot overnight and whilst its under cover, the air is damp and humid so working on the theory that it is condensation related, i'll clear some space in the garage and keep it in for a few nights and see if that relieves the issue. Either way i think it's time i got the inverter out, checked the board and check the enclosure for air entry points.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

did you conformal coat your board?
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

i did coat the board. recall it got very furry, i cleaned all that up and gave it a couple of coats.

I need to eyeball it again i think to see if that is working. could just be the inverter isn't well sealed but it needs to come out for inspection.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

Mines not sealed well at all and not had any similar issues.
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

interesting - i think i need to look at it

got it in the garage, that took about 10 trips and once it's working, it stays working

will see how it is in morning - trusty volvo on standby
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

so this morning after a night in the garage it was fine. another plus to the damp/condensation theory.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

Wow, inverter out and have a poke around time
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
arber333
Posts: 3181
Joined: Mon Dec 24, 2018 1:37 pm
Location: Slovenia
Has thanked: 71 times
Been thanked: 203 times
Contact:

Re: Morning trips

Post by arber333 »

FFMan wrote: Wed Nov 01, 2023 8:44 am so this morning after a night in the garage it was fine. another plus to the damp/condensation theory.
This is really a simple solution. You must have some flux left from soldering across those comparator chips. Flux is in general isolator but in case it gets damp it can conduct intermittently.
To get rid of it you need to wash/scrub your circuit with alcohol or nitro cleaner.
Only then go and paint it to protect against enviroment.
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

Ok - so a full day of troubleshooting and i think we found the cause...

A false dawn when i found one of the resolver pins on the amp seal had pooled a bit of solder and wasn't deep enough when the pin was inserted. But this wasn't the issue. We swapped the V1c board and bench check all the voltage etc to no avail, kept tripping with some shudder/grinding noise.

So we tried the motor spin in neutral (had been reluctant to do this before due to reported run aways) and it was all good. Jacked the rear wheels off the ground and tried it in gear but nasty sound and trip. Becoming increasingly convinced of a mechanical issue we dropped the gearbox and found that the motor end of my coupler severely worn and splines rounded off. Looked like the culprit, has been slipping under load, its now a baggy fit.

The finding fits with a couple of things in testing, worse first thing in the morning as where i park the car is over the 2 post lift, and the first thing the car has to do is climb over the central chain-way. More torque=slip. Secondly when we backed off the parameters and throtramp there was less load, so less slip, leading to thinking this was the cause. However the issue returned after a few miles.

I think the issue is that the alignment between gearbox and motor can't have been spot on, and over 1000 miles the splines on the coupler and possibly the motor have worn to the point they slip.

I need to get another diff to to see if the coupler and/or the motor is worn. Might just be the coupler, but splines on the motor show a wear line.

Looks like i'll need to remake the adapter plate with a little more precision, and get the coupler remade.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

OK - so I took the bits to a gearbox specialist I know at Silverstone. He lives and breathes road and race gearboxes.

So he think the coupler slipping is unlikely, although it shows signs of wear he points out that once a spline slips, it strips them all and you see shards of metal. It does not slip and then grip. Makes sense, only caveat is, inverter is tripping pretty quickly so it might be saving splines from being stripped.

He proposed that within the BMW gearbox some of the intermediate cogs are a press fit on the layshaft and under high torque can slip on the shaft. Once this happens it tends to get worse. This is known thing on some saloon cars put into racing, and is solved by welding the gears to the shaft.

So as an experiment I have procured another gearbox and will put this in with the motor and coupler and see if the issue disappears.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
johu
Site Admin
Posts: 5537
Joined: Thu Nov 08, 2018 10:52 pm
Location: Kassel/Germany
Has thanked: 147 times
Been thanked: 917 times
Contact:

Re: Morning trips

Post by johu »

Hmm, the only thing I do wonder about: why would the inverter trip when the shaft is misaligned?
Support R/D and forum on Patreon: https://patreon.com/openinverter - Subscribe on odysee: https://odysee.com/@openinverter:9
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

Agreed. I wonder if Toyota engineers have some check on their side.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

With it in gear and one wheel raised are you able to turn it by hand?
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

hard to tell at the moment as its in bits !

i'm not convinced by the gearbox issue but i have the spare as of tonight so will try it.

i still wonder if there is some current measure/limit issue that kicks in as soon as there is any load ? Process of elimination at this stage.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

My only thought was when in gear something was making it extremely difficult to spin.
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

So todays 6 hours work in -2c proved it's not a gearbox issue. Replacement gearbox the same. Trips as soon as any load is applied.

Current theory bad HV connection or contactor. Tomorrow will wire batteries direct to the inverter after a precharge and bypass all the contactors and precharge. I wonder if the main contactor has failed and i'm trying to turn the motor through the precharge resistor ? I did try and bypass the contactor but i think a full bypass with new wires is needed.

Backup plan, I now have an Outlander rear inverter, and code cribbed from here as a starting point, but am more keen to get the setup working that worked before. Hate bypassing an issue without understanding it. Besides if its a contactor/wiring issue the same issue will crop on Outlander inverter.

More time tomorrow...
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

So just to be clear, you've tried?
  • Replacement Inverter
  • Replacement Logic Board
  • Replacement Gearbox
Summary so far:
  • Motor spins ok in neutral
  • Pulling away gives overcurrent cutout
  • Seems to be ok once warm?
Trying to pull current though the pre-charge wouldn't give an overcurrent error, would just burn up the resistor. Could you send the log again?
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
FFMan
Posts: 297
Joined: Mon Jul 25, 2022 7:59 pm
Location: Bicester, Oxfordshire
Has thanked: 7 times
Been thanked: 44 times

Re: Morning trips

Post by FFMan »

Bigpie wrote: Sun Dec 03, 2023 8:25 am So just to be clear, you've tried?
  • Replacement Inverter
  • Replacement Logic Board
  • Replacement Gearbox
Summary so far:
  • Motor spins ok in neutral
  • Pulling away gives overcurrent cutout
  • Seems to be ok once warm?
Trying to pull current though the pre-charge wouldn't give an overcurrent error, would just burn up the resistor. Could you send the log again?
Yeah that's about it, except won't pull away now. Slightest load trips it, even putting in gear with wheels off the ground and trying to spin the wheels will trip it though they do occasionally spin. Problem has got progressively worse to this point. NO chance of driving it.

The replacement logic board didn't work out. it was reporting LORESAMP despite me applying the resistor mods in the wiki. It might have been damaged before as current connectors were on the wrong way round. It is an earlier version to mine.

i'm going add L1 and L2 to the logging and i'll attach a trace later with that in. I don't think a current clamp meter will catch the over current as its so quick to happen.
E46 touring
Phev rear motor, OEM inverter cabin heater and charger
BMW 9kwh & 12kwh packs
User avatar
Bigpie
Posts: 1564
Joined: Wed Apr 10, 2019 8:11 pm
Location: South Yorkshire, UK
Has thanked: 72 times
Been thanked: 286 times

Re: Morning trips

Post by Bigpie »

Mine shows LORESAMP, not sure that's a real problem.
VW Beetle 2003
Outlander front generator
Prius Gen 3 inverter (EVBMW logic board)
Outlander charger
3x Golf GTE batteries
Chademo Charging
Outlander water heater
Post Reply